Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 0.6.5
    • Component/s: Platform plugins
    • Labels:
      None
    • Environment:

      Amazon AMI (Xen), i386 (32 bit)

      Description

      Useful discussion of the source of the bug initiates here; https://bugzilla.redhat.com/show_bug.cgi?id=651861#c39.

      Seems to be caused by the Xen Hypervisor incorrectly handling cmov instructions containing a negative offset.

      The (interim) solution for this is to enable "nosegneg" flag https://bugzilla.redhat.com/show_bug.cgi?id=651861#c39 for AMI images - note that this should not be applied generally to all images produced as it would cause a noticeable performance impact.

      echo "hwcap 1 nosegneg" > /etc/ld.so.conf.d/libc6-xen.conf
      ldconfig

      Amazon should eventually fix this issue directly by applying a patch to their underlying xen hypervisor.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  goldmann Marek Goldmann
                  Reporter:
                  msavy Marc Savy
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: