Uploaded image for project: 'JBoss Enterprise BRMS Platform 5'
  1. JBoss Enterprise BRMS Platform 5
  2. BRMS-638

Repository initialization fails with ModeShape

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Migrated to another ITS
    • Affects Version/s: BRMS 5.2.0-Dev1
    • Fix Version/s: BRMS 5.2.0.GA
    • Component/s: BRM, Modeshape
    • Labels:
      None
    • Environment:

      Encountered with MySQL 5.1, MS SQL 2008, Oracle 11g R2. Not encountered with DB2 and PostgreSQL 8.4.

    • Affects Testing:
      Blocks Testing

      Description

      Exception is thrown during repository initialization, BRMS fails to deploy.

        Gliffy Diagrams

          Issue Links

            Activity

            rhauch Randall Hauch added a comment -

            It's strange that it works for some DBMSes but not others. Could this be due to the differences in transaction isolation level? That kind of makes sense that the database needs a bit more liberal isolation.

            I'd suggest changing the isolation level for Oracle or MySQL, and trying again. If that works, then try it for the other two DBMSes.

            rhauch Randall Hauch added a comment -

            Assigning to Kurt as he requested: "I would say the only way is to reproduce it in an integration test to reproduce, so that we can isolate and understand the issue, then if it turns out to be a ModeShape issue we can ask Randall for help. Please assign to me and i will take a look. It'd be great to have a debug trace of this as well."

            velias Vlastimil Eliáš added a comment -

            This issue was migrated to bugzilla.redhat.com

            jira-bugzilla-migration RH Bugzilla Integration added a comment -

            This issue has been migrated to Bugzilla bug 724798. Please note that this JIRA issue has been closed as part of the migration and therefore you will need to check the Bugzilla issue to find the current status.


              People

              • Assignee:
                kurtstam Kurt Stam
                Reporter:
                jlocker Jiri Locker
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development