Uploaded image for project: 'HornetQ'
  1. HornetQ
  2. HORNETQ-522

Reconnection issue when failover to backup server

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.1.2 Final
    • Fix Version/s: 2.2.0.GA
    • Component/s: Core
    • Labels:
      None

      Description

      To reproduce

      1. Set up a live server and a backup server.
      2. start a message sender to send messages to the live server and start a message receiver to receive it.
      3. during the send-receive process, kill -9 the live server and backup server takes over
      4. then messages are sent to the backup server but the messages won't be delivered to the receiver.

      It's look like a reconnection failed from client point of view. But investigation shows that the connection is established but the messages are not delivered for some reason yet to be found.

      So far I observed that the session reattachment seems to be the cause.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                gaohoward Howard Gao
                Reporter:
                gaohoward Howard Gao
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: