Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-5643

MainDeployer MBean methods don't work in JBoss 5.0 CR1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: JBossAS-5.0.0.Beta4
    • Fix Version/s: JBossAS-5.0.0.CR1
    • Component/s: Deployers
    • Labels:
      None
    • Environment:

      JDK 1.6.0_05, Windows XP64

      Description

      I know that the deployment was reworked, but I don't know which impacts this had on the MainDeployer MBean. At least it seems to be quite non-functional

      This is the state of the MainDeployer:
      -operation "listDeployed" and others just return nothing
      -"isDeployed (string)" works for a URL "file:/C:/temp/jboss-5.0.0.Beta4/server/default/deploy/KuchenZutatNM.ear", but not for "vfs:/C:/temp/jboss-5.0.0.Beta4/server/default/deploy/KuchenZutatNM.ear"
      -"undeploy" and others don't work for any of the above URLs, both result in a console output "21:11:45,890 WARN [MainDeployer] undeploy 'file:/C:/temp/jboss-5.0.0.Beta4/server/default/deploy/KuchenZutatNM.ear' : package not deployed"

      I created a small plugin for Eclipse WTP which tries to undeploy a module and waits for successful deployment of new modules, and this plugin does not work at all with JBoss 5. Probably I need to change it to use the new deployers, but I didn't find a hint to them.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  alesj Ales Justin
                  Reporter:
                  wolfgangknauf Wolfgang Knauf
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: