Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-27245

StackOverflowException when use module-alias in module.xml config

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.14.0.Final, 4.15.0.Final
    • Fix Version/s: 4.16.0.Final
    • Component/s: server
    • Labels:
      None
    • Sprint:
      devex #184 May 2020
    • Steps to Reproduce:
      Hide

      have an pre-installed jboss eap 6.4
      have an pre-installed eclipse IDE (tested with 2020-03)
      have installed jboss tools plugin from marketplace (tested with 4.14)
      open a workspace
      create the server with enviroment pointing to preview jboss installation
      start jboss (must run without failure)
      stop jboss
      close eclipse
      add a new module to jboss installation
      add two slots to module, one called "main" and another called "alternative"
      in "alternative" slot, add resources and depencencies to module.xml
      in "main" slot, set module.xml to use module-alias pointing to slot "alternative"
      start eclipse (on startup process several errors occurs pointing to StackOverflowException, see eclipse logs)

      Edit::

      • Create / use an enterprise projetct with an ejb-module, web-module and an ear project.
      • Reference jboss module on MANIFES.MF on both (ear / war projects)

      If you referer same module on both "MF" files you will get failure. If remove from "war" and restart eclipse, it starts up ok.

      Regards

      Show
      have an pre-installed jboss eap 6.4 have an pre-installed eclipse IDE (tested with 2020-03) have installed jboss tools plugin from marketplace (tested with 4.14) open a workspace create the server with enviroment pointing to preview jboss installation start jboss (must run without failure) stop jboss close eclipse add a new module to jboss installation add two slots to module, one called "main" and another called "alternative" in "alternative" slot, add resources and depencencies to module.xml in "main" slot, set module.xml to use module-alias pointing to slot "alternative" start eclipse (on startup process several errors occurs pointing to StackOverflowException, see eclipse logs) Edit:: Create / use an enterprise projetct with an ejb-module, web-module and an ear project. Reference jboss module on MANIFES.MF on both (ear / war projects) If you referer same module on both "MF" files you will get failure. If remove from "war" and restart eclipse, it starts up ok. Regards

      Description

      When we have a jboss eap 6.4 environment configured with a module in main slot pointing to a target slot via "module-alias" in module.xml ... eclipse workspace fail to startup with an stackoverflowexception message.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                rstryker Robert Stryker
                Reporter:
                marcosdonatobr MARCOS DONATO
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: