Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-4166

Seam Web EAR project using Seam 2.1.1.GA does not work on JBoss AS 4.2.3

    Details

      Description

      Created new seam web project using mysql connection (File>new>Seam Web Project) Select EAR project with seam 2.1.1.GA

      Ran project on JBoss 4.2.3 from JBoss Tools

      Get warning:
      13:40:57,481 WARN [MainDeployer] Found non-jar deployer for jboss-seam.jar: MBeanProxyExt[jboss.ejb3:service=EJB3Deployer]
      13:40:57,919 WARN [DeploymentInfo] Only the root deployment can set the loader repository, ignoring config=LoaderRepositoryConfig(repositoryName: seam.jboss.org:loader=infosys, repositoryClassName: org.jboss.mx.loading.HeirarchicalLoaderRepository3, configParserClassName: org.jboss.mx.loading.HeirarchicalLoaderRepository3ConfigParser, repositoryConfig: java2ParentDelegation=false)

      Project failed to run
      :13:41:21,513 WARN [SeamPhaseListener] uncaught exception, passing to exception handler
      java.lang.IllegalStateException: No phase id bound to current thread (make sure you do not have two SeamPhaseListener instances installed)

      Traceback similar to post in JBoss Forum

      Exporting ear file works (when ear file copied manually to deploy folder, along with ds file)

        Gliffy Diagrams

          Attachments

          1. infosys-ds.xml
            0.7 kB
          2. infosys-ear.ear
            9.02 MB
          3. infosys-ear.zip
            9.04 MB
          4. JBIDE4166.patch
            6 kB

            Issue Links

              Activity

                People

                • Assignee:
                  snjeza Snjezana Peco
                  Reporter:
                  bdlink Bruce Link
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: