Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-6300

Tycho-based Drools build depends on JSF; refactor out common bot test framework code into tests/ or common/ module

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.2.x
    • Fix Version/s: 3.2.0.M2
    • Component/s: arquillian
    • Labels:
      None

      Description

      [Software being installed: org.jboss.tools.drools.ui.bot.test 1.0.0.qualifier, Missing requirement: org.jboss.tools.drools.ui.bot.test 1.0.0.qualifier requires 'bundle org.jboss.tools.ui.bot.ext 1.0.0' but it could not be found]

      Required plugin, org.jboss.tools.ui.bot.ext, is located in jst/tests/org.jboss.tools.ui.bot.ext, which changes the order in which components must be built.

      Currently, drools only depends on tests and common. To add this new bot test requires either that it now depend on xulrunner & jst, or that the bot.ext plugin be moved upstream into tests/ or common/. I prefer to move it upstream than to push Drools downstream.

      Can that be done?

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  dgolovin Denis Golovin
                  Reporter:
                  nickboldt Nick Boldt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: