Uploaded image for project: 'JBoss OSGi'
  1. JBoss OSGi
  2. JBOSGI-285

Add JSP support for WebApps

    Details

    • Type: Feature Request
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: JBossOSGi 1.1.0
    • Component/s: None
    • Labels:
      None

      Description

      It seems that another jar is missing from distribution, the Pax Web Extender JSP, as the log message says:

      WARN [RegisterWebAppVisitorWC] Jsp support is not enabled. Is org.ops4j.pax.web.jsp bundle installed?

      Obviously not! So I downloaded the latest version (0.7.1) of Pax Web Extender JSP and successfully deployed it:

      INFO [BundleStartStopDeployer] Started: org.ops4j.pax.web.pax-web-extender-war [16]
      INFO [Activator] Pax Web started
      INFO [BundleStartStopDeployer] Started: org.ops4j.pax.web.pax-web-jetty-bundle [17]
      INFO [JettyServerImpl] Pax Web available at [0.0.0.0]:[8090]
      INFO [HttpServiceFactoryImpl] Binding bundle: [jboss-osgi-webconsole [12]] to http service
      INFO [BundleStartStopDeployer] Started: org.ops4j.pax.web.pax-web-jsp [18]

      But it doesn't seems to work because I always get the same WARN message above... suggestions?

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  thomas.diesler Thomas Diesler
                  Reporter:
                  thomas.diesler Thomas Diesler
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: