Uploaded image for project: 'JBoss OSGi'
  1. JBoss OSGi
  2. JBOSGI-762

Register BundleReferenceClassLoader as parallel-capable due to changes in jboss-modules

    Details

    • Type: Enhancement
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: JBossOSGi 2.1.1
    • Fix Version/s: JBossOSGi 2.2.0
    • Component/s: framework
    • Labels:
      None

      Description

      Because of JDK7 related changes in jboss-modules ([1] [2]) the BundleReferenceClassLoader has to be registered as parallel-capable. Otherwise it will fail with java.lang.Error: Cannot instantiate non-parallel subclass in the EAP once jboss-modules:1.3.1.Final is in.

      [1] https://issues.jboss.org/browse/MODULES-181
      [2] https://issues.jboss.org/browse/MODULES-182

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                istudens Ivo Studensky
                Reporter:
                istudens Ivo Studensky
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: