Uploaded image for project: 'Seam 2'
  1. Seam 2
  2. JBSEAM-1998

javassist 3.3 and 3.4 are both imported by maven when I declare hibernate dependency

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.0.0.CR2
    • Component/s: None
    • Labels:
      None

      Description

      I have the following dependencies defined:

      <dependency>
      <groupId>org.hibernate</groupId>
      <artifactId>hibernate</artifactId>
      </dependency>

      <dependency>
      <groupId>org.hibernate</groupId>
      <artifactId>hibernate-validator</artifactId>
      </dependency>

      <dependency>
      <groupId>org.hibernate</groupId>
      <artifactId>hibernate-annotations</artifactId>
      </dependency>

      <dependency>
      <groupId>org.hibernate</groupId>
      <artifactId>hibernate-entitymanager</artifactId>
      </dependency>

      And the generate WAR has both:

      javassist-3.3.ga.jar
      javassist-3.4.GA.jar

      Perhaps one of them should be removed. Thanks.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                pmuir Pete Muir
                Reporter:
                juntao Michael Yuan (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: