Uploaded image for project: 'Seam 2'
  1. Seam 2
  2. JBSEAM-3858

Creating jBPM process with a jboss tools created Seam project doesn't work, Hibernate problems

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: 2.1.0.SP1, 2.1.1.CR1
    • Fix Version/s: None
    • Component/s: BPM
    • Labels:
    • Environment:

      JBoss Application Server 4.2.3 GA, Eclipse Ganymede, JBoss Tools 3.0.0.beta1

      Description

      I've created a Seam Web Project at Eclipse with JBoss Tools 3.0.0.beta1. I can deploy and run it at JBoss Application Server ok, I can even create a new entity CRUD perfectly.

      My problem comes when I create a jBPM process. I create it with JBoss Tools also and insert it at components.xml with the following code:
      <bpm:jbpm>
      <bpm:process-definitions>
      <value>proyecto/processdefinition.xml</value>
      </bpm:process-definitions>
      </bpm:jbpm>

      When I do it it first asked for a missing hibernate.cfg.xml. I created an almost empty one:
      <?xml version='1.0' encoding='utf-8'?>

      <!DOCTYPE hibernate-configuration PUBLIC
      "-//Hibernate/Hibernate Configuration DTD 3.0//EN"
      "http://hibernate.sourceforge.net/hibernate-configuration-3.0.dtd">

      <hibernate-configuration>
      <session-factory>
      <property name="connection.datasource">java:/incidosDatasource</property>
      <mapping resource="org/jbpm/db/hibernate.queries.hbm.xml" />
      </session-factory>

      </hibernate-configuration>

      The mapping was also needed. Without it Hibernate couldn't find a jBPM named query.

      Nevertheless it keeps throwing an exception I can't fix:

      Caused by: java.lang.RuntimeException: could not deploy a process definition
      at org.jboss.seam.bpm.Jbpm.installProcessDefinitions(Jbpm.java:296)
      ...
      Caused by: java.lang.IllegalArgumentException: Parameter name does not exist as a named parameter in [

      select pd
      from org.jbpm.graph.def.ProcessDefinition as pd
      where pd.name = :name
      order by pd.version desc

      ]
      at org.hibernate.impl.AbstractQueryImpl.setParameter(AbstractQueryImpl.java:356)
      at org.hibernate.impl.AbstractQueryImpl.setString(AbstractQueryImpl.java:643)
      at org.jbpm.db.GraphSession.findLatestProcessDefinition(GraphSession.java:151)
      ... 154 more
      17:55:17,859 ERROR [StandardContext] Error listenerStart

      I've tried both 2.1.1.CR1 and 2.1.0.SP1, same result. It happens both with testing and at deploy time.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                juanignaciosl Juan Ignacio Sánchez Lara
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: