Uploaded image for project: 'Seam 2'
  1. Seam 2
  2. JBSEAM-4700

Hibernate Search 3.2 onwards is not properly detected by Seam 2

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.2.1.CR2
    • Fix Version/s: 2.2.1.CR3
    • Component/s: Search
    • Labels:
      None

      Description

      HibernatePersistenceProvider incorrectly relies on the presence of the Version#VERSION field which is not present in Hibernate 3.2 onwards.

      This detection code was here to allow support for Hibernate Search 3.0 which we can safely ignore now.

      The code can be made much more straightforward by only keeping the code inside if (version != null) { } (and keep the try catch surrounding).

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  epbernard Emmanuel Bernard
                  Reporter:
                  epbernard Emmanuel Bernard
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: