Uploaded image for project: 'JBoss Web Services'
  1. JBoss Web Services
  2. JBWS-1702

Type inheritance with document/literal/wrapped

    Details

      Description

      I have a problem with the new JBossWS-1.2.1.GA in JBoss 4.2.0.GA and inheritance.
      To describe this problem first I have to describe my code structure:

      For an example I have three classes (ClassA, ClassB and ClassC). ClassC inherits of ClassB and ClassB inherits of ClassA (ClassA --> ClassB --> ClassC). Now I have a webservice method that returns ClassB. In this method an instance of ClassC is being created and returned. This was not a problem in the former JBossWS version (and also in the other J2EE 4 styled webservices) but now in JBossWS 1.2 I only get returned an object of ClassB but I supposed to get an obejct of ClassC.

      Code:

      public class ClassA {
      private String propA;

      // here setter and getter for propA
      ......
      }

      public class ClassB extends ClassA {

      private String propB;
      // here setter and getter for propB
      ......
      }

      public class ClassC extends ClassC {
      private String propC;
      // here setter and getter for propC
      ......
      }

      @WebService
      @SOAPBinding( style = SOAPBinding.Style.DOCUMENT, use = SOAPBinding.Use.LITERAL, parameterStyle = SO
      APBinding.ParameterStyle.WRAPPED )
      public class MyWebService {

      @WebMethod()
      public ClassB getClassB()

      { ClassC classC = new ClassC(); classC.setPropA("propA"); return classC; }

      /**

      • --> this method is only used to publish ClassC otherwise it is not known
      • in this webservice
        */
        @WebMethod()
        public ClassC getClassC() { ClassC classC = new ClassC(); classC.setPropA("propA"); return classC; }

      }

      }
      Now I call getClassB() and the result that I got is an object of ClassB and not of ClassC.

      What can I do to get an object of ClassC. I also looked at the returned SOAP message and there you can see that only informations about the ClassB instance are submitted. In JBoss 4.0.5 (JBossWS1.0.3) the SOAP message contains the type of the returned object and all data are being submitted correctly.

      I also tried the SOAP parameter style BARE but nothing changed. And whenI use RPC/Literal then I get an error in the .NET Client that an instance of ClassB was expected but got an instance of ClassC. I also tried it with a JAVA client but there was the same occurance.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                heiko.braun Heiko Braun
                Reporter:
                thomas.diesler Thomas Diesler
              • Votes:
                5 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: