Uploaded image for project: 'RiftSaw'
  1. RiftSaw
  2. RIFTSAW-87

Seeing java.lang.UnsupportedOperationException when running with JDK 1.5 version of JBoss AS 5.1.0

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Rejected
    • Affects Version/s: 2.0-M2
    • Fix Version/s: 2.0-CR1
    • Component/s: Integration
    • Labels:
      None

      Description

      Seeing this when deploying any of the quickstarts to Riftsaw built from trunk (with Sun JDK 1.5) and JBoss AS 5.1.0 GA:

      21:07:09,381 ERROR [SOAPFaultHelperJAXWS] SOAP request exception
      java.lang.UnsupportedOperationException: setProperty must be
      overridden by all subclasses of SOAPMessage
      at javax.xml.soap.SOAPMessage.setProperty(SOAPMessage.java:445)

      Running with the JDK 1.6 version of AS 5.1 (http://sourceforge.net/projects/jboss/files/JBoss/JBoss-5.1.0.GA/jboss-5.1.0.GA-jdk6.zip) resolves the problem.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  objectiser Gary Brown
                  Reporter:
                  ldimaggio Len DiMaggio
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: