Uploaded image for project: 'JBoss Enterprise SOA Platform'
  1. JBoss Enterprise SOA Platform
  2. SOA-3051

JBDS 4 - SOA-P 4.3 CP05 incompatibility - creating new Drools project - multiple warnings are displayed

    Details

    • Release Notes Text:
      Hide
      https://issues.jboss.org/browse/SOA-3051

      Users may encounter warning messages if the set Rules project code compatibility to JBoss Rules 4.x. These are caused by examples that use pre-5.x API calls and are intended to discourage users from accessing the internal API. If, however, you do need to access the API, you can turn them off by going to Windows - Preferences - JBoss Rules and setting the set internal classes to accessible.
      Show
      https://issues.jboss.org/browse/SOA-3051 Users may encounter warning messages if the set Rules project code compatibility to JBoss Rules 4.x. These are caused by examples that use pre-5.x API calls and are intended to discourage users from accessing the internal API. If, however, you do need to access the API, you can turn them off by going to Windows - Preferences - JBoss Rules and setting the set internal classes to accessible.
    • Release Notes Docs Status:
      Documented as Known Issue

      Description

      The problem looks like that JBDS 4 requires/assumes a Drools 5 runtime.

      The new Drools project references api elements that did not exist before Drools 5 - such as: org.drools.KnowledgeBase

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  dlesage David Le Sage
                  Reporter:
                  ldimaggio Len DiMaggio
                  Writer:
                  David Le Sage
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: