Uploaded image for project: 'TorqueBox'
  1. TorqueBox
  2. TORQUE-77

task issues on both torquebox beta19 and master branch

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 1.0.0.Beta19
    • Fix Version/s: 1.0.0.Beta20
    • Component/s: Queues
    • Labels:
      None
    • Environment:

      Mac OS X Snow Leopard
      Java 1.6.x

      Description

      There are some issues with tasks in both the 1.0.0.Beta19 tag and master. I'm using the tasks functionality within torquebox b19, and unfortunately it fails on deployment due to the fact that one of the queue's dependencies attempts to deploy before the queue itself deploys..

      I took a look at the TB git repository, and it seems that you'd already solved this issue on master, so I got the latest from git, built it, and installed the resulting deployer/gems.

      With the code from master, my app deploys successfully, but I ran into another issue when when sending tasks. The stack trace from that issue is as follows:

      18:10:36,774 ERROR [STDERR] /Users/mdobozy/Development/AppServers/torquebox-1.0.0.Beta19-bin/jruby/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:440:in `load_missing_constant': uninitialized constant TorqueBox::Messaging::Dispatcher::EventNotifierTask (NameError)
      18:10:36,775 ERROR [STDERR] from /Users/mdobozy/Development/AppServers/torquebox-1.0.0.Beta19-bin/jruby/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:80:in `const_missing_with_dependencies'
      18:10:36,775 ERROR [STDERR] from (eval):1:in `dispatch'
      18:10:36,775 ERROR [STDERR] ...internal jruby stack elided...
      18:10:36,775 ERROR [STDERR] from ActiveSupport::Dependencies.load_missing_constant(/Users/mdobozy/Development/AppServers/torquebox-1.0.0.Beta19-bin/jruby/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:80)
      18:10:36,776 ERROR [STDERR] from ActiveSupport::Dependencies::ModuleConstMissing.const_missing_with_dependencies((eval):1)
      18:10:36,776 ERROR [STDERR] from #<Class:01x3eee7317>.dispatch(<script>:1)
      18:10:36,776 ERROR [STDERR] from Kernel.eval(/Users/mdobozy/Development/AppServers/torquebox-1.0.0.Beta19-bin/jruby/lib/ruby/gems/1.8/gems/torquebox-messaging-container-1.0.0/lib/torquebox/messaging/dispatcher.rb:7)
      18:10:36,776 ERROR [STDERR] from #<Class:01x3eee7317>.dispatch(<script>:1)
      18:10:36,777 ERROR [STDERR] from (unknown).(unknown)(:1)

      The cause of the error is the messaging/container/lib/torquebox/messaging/dispatcher.rb module, which tries to eval the listener_class_name that was passed in. Unfortunately, the classes in app/tasks haven't been loaded at that point, so the eval fails. Loading the classes prior to the eval fixes the issue.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                bob.mcwhirter Bob McWhirter
                Reporter:
                dobozysaurus Michael Dobozy
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: