Uploaded image for project: 'Weld'
  1. Weld
  2. WELD-508

incorrect choice of dependency in example: jboss-ejb3-api-3.1.0.jar

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Rejected
    • Affects Version/s: 1.0.1.Final
    • Fix Version/s: None
    • Component/s: Examples
    • Labels:
      None

      Description

      C:\java\weld-1.0.1-Final\examples\jsf\translator>mvn clean install

      [ERROR] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Compilation failure
      C:\java\weld-1.0.1-Final\examples\jsf\translator\ejb\src\main\java\org\jboss\wel
      d\examples\translator\SentenceTranslator.java:[3,-1] cannot access javax.ejb.Sta
      teless
      bad class file: C:\Documents and Settings\asookazian\.m2\repository\org\jboss\ej
      b3\jboss-ejb3-api\3.1.0\jboss-ejb3-api-3.1.0.jar(javax/ejb/Stateless.class)
      class file has wrong version 50.0, should be 49.0

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  pmuir Pete Muir
                  Reporter:
                  asookazian Arbi Sookazian
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: